2 Monitors problem

I’m having problem with my 2 monitor setup:

  1. Lenovo laptop with 1920x1080 screen 60Hz @ 96dpi
  2. External monitor: LG 2560x1080x60Hz @ 96dpi

I can extend the external monitor to the left or the right, but I cannot mirror the laptop on the external monitor.

The mirror option is disabled.

I was able to borrow a very similar laptop with opensuse/kde and hooked my external monitor. I was able to mirror the laptop (under kde) to the external at: 1920x1080 (which is what I want for mirror.

Any suggestion?


Here’s my inxi with the manjaro xfce live

$ inxi -Fxxxz
System:    Kernel: 5.13.19-2-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 Desktop: Xfce 4.16.0 tk: Gtk 3.24.29
            info: xfce4-panel wm: xfwm 4.16.1 vt: 7 dm: LightDM 1.30.0 Distro: Manjaro Linux base: Arch Linux
Machine:   Type: Convertible System: LENOVO product: 81X2 v: IdeaPad Flex 5 14ARE05 serial: <filter> Chassis: type: 31
            v: IdeaPad Flex 5 14ARE05 serial: <filter>
            Mobo: LENOVO model: LNVNB161216 v: SDK0J40709 WIN serial: <filter> UEFI: LENOVO v: EECN36WW date: 05/17/2021
Battery:   ID-1: BAT0 charge: 31.9 Wh (60.8%) condition: 52.5/52.5 Wh (100.0%) volts: 11.1 min: 11.5 model: Celxpert L19C3PD6
            type: Li-poly serial: <filter> status: Unknown cycles: 1
CPU:       Info: 8-Core model: AMD Ryzen 7 4700U with Radeon Graphics bits: 64 type: MCP arch: Zen 2 rev: 1 cache: L2: 4 MiB
            flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 31952
            Speed: 1397 MHz min/max: 1400/2000 MHz boost: enabled Core speeds (MHz): 1: 1397 2: 1345 3: 1397 4: 1398 5: 1397
            6: 1397 7: 1397 8: 1397
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Renoir vendor: Lenovo driver: amdgpu v: kernel bus-ID: 04:00.0
            chip-ID: 1002:1636 class-ID: 0300
            Device-2: Syntek Integrated Camera type: USB driver: uvcvideo bus-ID: 1-4:5 chip-ID: 174f:243f class-ID: 0e02
            serial: <filter>
            Display: x11 server: X.Org 1.20.13 compositor: xfwm4 v: 4.16.1 driver: loaded: amdgpu,ati unloaded: modesetting
            alternate: fbdev,vesa resolution: 2560x1080~60Hz s-dpi: 96
            OpenGL: renderer: AMD RENOIR (DRM 3.41.0 5.13.19-2-MANJARO LLVM 12.0.1) v: 4.6 Mesa 21.2.2 direct render: Yes
Audio:     Device-1: Advanced Micro Devices [AMD/ATI] driver: snd_hda_intel v: kernel bus-ID: 04:00.1 chip-ID: 1002:1637
            class-ID: 0403
            Device-2: Advanced Micro Devices [AMD] Raven/Raven2/FireFlight/Renoir Audio Processor vendor: Lenovo driver: N/A
            bus-ID: 04:00.5 chip-ID: 1022:15e2 class-ID: 0480
            Device-3: Advanced Micro Devices [AMD] Family 17h HD Audio vendor: Lenovo driver: snd_hda_intel v: kernel
            bus-ID: 04:00.6 chip-ID: 1022:15e3 class-ID: 0403
            Sound Server-1: ALSA v: k5.13.19-2-MANJARO running: yes
            Sound Server-2: JACK v: 1.9.19 running: no
            Sound Server-3: PulseAudio v: 15.0 running: yes
            Sound Server-4: PipeWire v: 0.3.37 running: no
Network:   Device-1: Realtek RTL8822CE 802.11ac PCIe Wireless Network Adapter vendor: Lenovo driver: rtw_8822ce v: N/A
            port: 2000 bus-ID: 02:00.0 chip-ID: 10ec:c822 class-ID: 0280
            IF: wlp2s0 state: down mac: <filter>
            Device-2: Realtek RTL8153 Gigabit Ethernet Adapter type: USB driver: r8152 bus-ID: 2-1.4:3 chip-ID: 0bda:8153
            class-ID: 0000 serial: <filter>
            IF: enp4s0f3u1u4 state: up speed: 1000 Mbps duplex: full mac: <filter>
Bluetooth: Device-1: Realtek Bluetooth Radio type: USB driver: btusb v: 0.8 bus-ID: 3-4:3 chip-ID: 0bda:c123 class-ID: e001
            serial: <filter>
            Report: rfkill ID: hci0 rfk-id: 3 state: down bt-service: enabled,running rfk-block: hardware: no software: yes
            address: see --recommends
Drives:    Local Storage: total: 506.02 GiB used: 0 KiB (0.0%)
            ID-1: /dev/nvme0n1 vendor: Samsung model: MZVLB512HBJQ-000L2 size: 476.94 GiB speed: 31.6 Gb/s lanes: 4 type: SSD
            serial: <filter> rev: 3L1QEXF7 temp: 34.9 C scheme: GPT
            ID-2: /dev/sda type: USB vendor: Kingston model: DataTraveler 3.0 size: 29.08 GiB type: N/A serial: <filter>
            rev: PMAP scheme: MBR
Partition: Message: No partition data found.
Swap:      Alert: No swap data was found.
Sensors:   System Temperatures: cpu: 45.4 C mobo: 36.0 C gpu: amdgpu temp: 38.0 C
            Fan Speeds (RPM): N/A
Info:      Processes: 262 Uptime: 4m wakeups: 5 Memory: 15.01 GiB used: 1.47 GiB (9.8%) Init: systemd v: 249 Compilers:
            gcc: N/A Packages: pacman: 1124 Shell: Bash v: 5.1.8 running-in: xfce4-terminal inxi: 3.3.06
1 Like

What happens if you use xrandr to set the resolutions?

xrandr --output eDP1 --auto --output HDMI2 --auto --same-as eDP1

This assumes that eDP1 is your laptop screen and HDMI2 is where your external screen is connected

1 Like

Excellent :smiley: Thank you for taking the time.

I didn’t think of xrandr. I should have. That got me going. Switching to:

--mode 1920x1080

did the mirror on the external monitor and centered the output of the laptop on the external monitor.

What surprised me was that even after getting it to work “properly” when I went in the settings > hardware > display, the mirror option was still not available.

But now it works. Thank you, very appreciated.

Now this weekend, I’ll be able to upgrade to Manjaro.

I’ve marked this answer as the solution to your question as it is by far the best answer you’ll get.

However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (If you disagree with my choice, just send me a personal message and explain why I shouldn’t have done this or :heart: or :+1: if you agree)

P.S. In the future, please don’t forget to come back to your question after your issue has been solved and click the 3 dots below the answer to mark a solution like this below the answer that helped you most:
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

Oops: sorry, I forgot

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.