2 boot menus after installing Manjaro alongside Mint

I have installed Manjaro alongside an existing Mint system. Now whenever I boot I get 2 boot menus (not sure if that’s the best way to phase it):

  • The first is text-only and seems to be installed by Mint, it has an option for Manjaro but it does not boot (but fallback to initramfs does)
  • Then if I press “esc” from there, and type exit in the grub command prompt I get the 2nd graphic boot menu (seems to belong to Manjaro) and from there Manjaro boots fine.

Is there any way to have just one menu? Ideally I’d like to boot straight to Manjaro but also have an option to boot into Mint as well.

I went through the steps described on the wiki page Restore_the_GRUB_Bootloader (not allowed to post links) but it didn’t help.

Appreciate any advice.

parted -l

Model: ATA ST2000DM008-2FR1 (scsi)
Disk /dev/sda: 2000GB
Sector size (logical/physical): 512B/4096B
Partition Table: loop
Disk Flags: 

Number  Start  End     Size    File system  Flags
 1      0.00B  2000GB  2000GB  ext4

Model: CT1000P1SSD8 (nvme)
Disk /dev/nvme0n1: 1000GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size   File system  Name                  Flags
 1      1049kB  538MB   537MB  fat32        EFI System Partition  boot, esp
 2      538MB   500GB   500GB  ext4
 3      500GB   1000GB  500GB  ext4


TARGET                         SOURCE         FSTYPE         OPTIONS
/                              /dev/nvme0n1p3 ext4           rw,noatime
├─/proc                        proc           proc           rw,nosuid,nodev,noexec,relatime
│ └─/proc/sys/fs/binfmt_misc   systemd-1      autofs         rw,relatime,fd=30,pgrp=1,timeout=0,minproto=5,maxproto=5,direct,pipe_ino=14588
│   └─/proc/sys/fs/binfmt_misc binfmt_misc    binfmt_misc    rw,nosuid,nodev,noexec,relatime
├─/sys                         sys            sysfs          rw,nosuid,nodev,noexec,relatime
│ ├─/sys/firmware/efi/efivars  efivarfs       efivarfs       rw,nosuid,nodev,noexec,relatime
│ ├─/sys/kernel/security       securityfs     securityfs     rw,nosuid,nodev,noexec,relatime
│ ├─/sys/fs/cgroup             cgroup2        cgroup2        rw,nosuid,nodev,noexec,relatime,nsdelegate,memory_recursiveprot
│ ├─/sys/fs/pstore             pstore         pstore         rw,nosuid,nodev,noexec,relatime
│ ├─/sys/fs/bpf                none           bpf            rw,nosuid,nodev,noexec,relatime,mode=700
│ ├─/sys/kernel/tracing        tracefs        tracefs        rw,nosuid,nodev,noexec,relatime
│ ├─/sys/kernel/debug          debugfs        debugfs        rw,nosuid,nodev,noexec,relatime
│ ├─/sys/kernel/config         configfs       configfs       rw,nosuid,nodev,noexec,relatime
│ └─/sys/fs/fuse/connections   fusectl        fusectl        rw,nosuid,nodev,noexec,relatime
├─/dev                         dev            devtmpfs       rw,nosuid,relatime,size=8148608k,nr_inodes=2037152,mode=755,inode64
│ ├─/dev/shm                   tmpfs          tmpfs          rw,nosuid,nodev,inode64
│ ├─/dev/pts                   devpts         devpts         rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000
│ ├─/dev/hugepages             hugetlbfs      hugetlbfs      rw,relatime,pagesize=2M
│ └─/dev/mqueue                mqueue         mqueue         rw,nosuid,nodev,noexec,relatime
├─/run                         run            tmpfs          rw,nosuid,nodev,relatime,mode=755,inode64
│ └─/run/user/1000             tmpfs          tmpfs          rw,nosuid,nodev,relatime,size=1637820k,nr_inodes=409455,mode=700,uid=1000,gid=1000,inode64
│   └─/run/user/1000/gvfs      gvfsd-fuse     fuse.gvfsd-fus rw,nosuid,nodev,relatime,user_id=1000,group_id=1000
├─/tmp                         tmpfs          tmpfs          rw,nosuid,nodev,nr_inodes=409600,inode64
└─/boot/efi                    /dev/nvme0n1p1 vfat           rw,relatime,fmask=0077,dmask=0077,codepage=437,iocharset=ascii,shortname=mixed,utf8,errors=remo

Change Manjaro to your primary boot option in BIOS settings.


Thanks @anon59284200 - that fixed it.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.