17.x calamares crash


I ran the command from the live cd/usb: sudo -E calamares -d as when I run calamares, it briefly loads then crashes.

End of the terminal displays: 07:37:36 [0]: void Calamares::Module::loadConfigurationFile(const QString&) bad module configuration format “/usr/share/calamares/modules/umount.conf” 07:37:36 [1]: LAST VS IS EVS! 07:37:36 [1]: ViewModule “finished@finished” loading complete. 07:37:36 [1]: STARTUP: loadModules for all modules done 07:37:37 [1]: STARTUP: Window now visible and ProgressTreeView populated 07:37:37 [1]: Need at least storage bytes: 8482560409 07:37:37 [1]: Need at least ram bytes: 1073741824 07:37:37 [1]: A battery exists, checking for mains power. 07:37:37 [1]: enoughStorage, enoughRam, hasPower, hasInternet, isRoot: true true true true true 07:37:37 [8]: getting bad sectors failed for “/dev/sda” : No such file or directory No layout variant specified on the command line Trailing -variant option ignored 07:37:37 [1]: xkbmap selection changed to: “us” - “” terminate called after throwing an instance of ‘YAML::ParserException’ what(): yaml-cpp: error at line 20, column 80: illegal map value Aborted

Any idea how to get this installing?
Ive checksumed the iso, tried burning to dvd and different usb drives. Tried a few different machines, including virtual box.
All get the same error.
Tried older and other version of manjaro too!

How does anyone install this? How can i fix this error?

Problem Installing Manjaro on Acer Chromebook

I have one ‘problematic’ computer, I tried 7-8 different Manjaro flavors, systemd, OpenRC with newer Calamares and every single installation failed.

Then I tried with Manjaro-Architect and got it working. You could try it. It is a little bit less beginner proof, but there is a great tutorial on this forum that will guide you. I don’t have a link to it handy, sorry, and disabled all java-script and other similar things in this browser, can’t search this forum, so I will have you do the searching :slight_smile:

Oberon wrote the guide.


Tutorial for Manjaro-Architect:


This issue is already reported upstream. What happens if a new file gets created with following content?


srcLog:      "/root/.cache/Calamares/Calamares/Calamares.log"
destLog:     "/var/log/Calamares.log"


i found the solution is to disable the network, either physically or via network manager.
Ive posted more info here:


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.