Author Topic: [Solved] Setting Resolution - Maximized Windows wrong size  (Read 1132 times)

0 Members and 1 Guest are viewing this topic.

Offline darkcityTopic starter

  • Neuling
  • *
  • Posts: 8
  • Kernel: Linux 3.10.13-1-MANJARO (x86_64)
  • Desktop: Openbox
  • Branch: stable
  • GPU Card: [AMD/ATI] RV100 [Radeon 7000 / Radeon VE]
  • GPU driver: radeon
  • Skill: Novice
[Solved] Setting Resolution - Maximized Windows wrong size
« on: 07. October 2013, 12:42:53 »
Hi

My first problem was making Manjaro (Openbox 64bit) remember my screen size resolution.  It defaulted to 800x600, where as I wanted 1024x768.  ARandr could set to larger size but wouldn't keep that size next time I logged in.

I solve that problem making a 10-monitor.conf file.

---

My new problem is when I maximize windows - they only behave as if my screen is 800x600 not 1024x768 - ie too small.

Any suggestions appreciated.

« Last Edit: 14. October 2013, 15:53:06 by darkcity »

Offline darkcityTopic starter

  • Neuling
  • *
  • Posts: 8
  • Kernel: Linux 3.10.13-1-MANJARO (x86_64)
  • Desktop: Openbox
  • Branch: stable
  • GPU Card: [AMD/ATI] RV100 [Radeon 7000 / Radeon VE]
  • GPU driver: radeon
  • Skill: Novice
Re: Setting Resolution - Maximized Windows wrong size
« Reply #1 on: 09. October 2013, 16:14:03 »
Still no joy finding a solution.

Is the desktop height and width normally set when screen resolution is set?

Is it controlled by xorg or openbox?

Added pic to illustrate the problem  8)

Offline Rob

  • Core Team
  • *****
  • Posts: 4722
  • Alias: Korrode
  • Kernel: linux314 x64
  • Desktop: Xfce+Compiz
  • Branch: Unstable
  • GPU Card: nVidia GTX560Ti
  • GPU driver: non-free
  • Skill: Advanced
Re: Setting Resolution - Maximized Windows wrong size
« Reply #2 on: 09. October 2013, 16:20:41 »
I solve that problem making a 10-monitor.conf file.
Where is this file placed and what does it contain?

Is it controlled by xorg or openbox?
Ultimately it's controlled by Xorg.

Offline darkcityTopic starter

  • Neuling
  • *
  • Posts: 8
  • Kernel: Linux 3.10.13-1-MANJARO (x86_64)
  • Desktop: Openbox
  • Branch: stable
  • GPU Card: [AMD/ATI] RV100 [Radeon 7000 / Radeon VE]
  • GPU driver: radeon
  • Skill: Novice
Re: Setting Resolution - Maximized Windows wrong size
« Reply #3 on: 09. October 2013, 22:26:34 »
Thanks for the reply.  Manjaro defaults the display to 800x600.  I tried setting the resolution via ARandR and LXrandr. I could set resolution to 1024x768, but it wasn't persistent after I rebooted and I had the maximize window problem.

Then I followed a guide on the Arch Linux wiki https://wiki.archlinux.org/index.php/Xorg#Monitor_Settings.

I created the file /etc/X11/xorg.conf.d/10-monitor.conf containing-

Code: [Select]
Section "Monitor"
    Identifier             "Monitor0"
EndSection

Section "Device"
    Identifier             "Device0"
    Driver                 "radeon" #Choose the driver used for this monitor
EndSection

Section "Screen"
    Identifier             "Screen0"  #Collapse Monitor and Device section to Screen section
    Device                 "Device0"
    Monitor                "Monitor0"
    DefaultDepth           16 #Choose the depth (16||24)
    SubSection             "Display"
        Depth              16
        Modes              "1024x768" #Choose the resolution
    EndSubSection
EndSection

Now Manjaro boots with 1024x768 resolution, but I still have the maximize problem.  Other distros have be able to find the 1024x768 resolution okay, I wonder if it could be a driver problem?

Offline darkcityTopic starter

  • Neuling
  • *
  • Posts: 8
  • Kernel: Linux 3.10.13-1-MANJARO (x86_64)
  • Desktop: Openbox
  • Branch: stable
  • GPU Card: [AMD/ATI] RV100 [Radeon 7000 / Radeon VE]
  • GPU driver: radeon
  • Skill: Novice
Re: Setting Resolution - Maximized Windows wrong size
« Reply #4 on: 14. October 2013, 15:25:50 »
I found a solution using xrandr's size, though its a bit of a hack. 
using
xrandr --size 1024x768
on its own doesn't work, but if I make the --size smaller then back it the size I want it works.

So I adding this code at the top of openbox autostart

~/.config/openbox/autostart

Code: [Select]
##make area desktop right size - ie the size openbox think the screen is
# hack - just setting correct size doesn't work
# set smaller wait a second - allow xrandr to work, then set bigger
(xrandr --size 800x600 && sleep 1s && xrandr --size 1024x768) &

this is in addition to adding the 10-monitor.conf file (see above).

now I can get on with using manjaro  :)
« Last Edit: 14. October 2013, 15:52:18 by darkcity »