Author Topic: Sound Problems!  (Read 2379 times)

0 Members and 1 Guest are viewing this topic.

Offline aadityaTopic starter

  • Support Team
  • ****
  • Posts: 1334
    • My Website
  • Kernel: Linux-3.13-x86_64
  • Desktop: Xfce
  • Branch: Testing
  • GPU Card: Intel HD 4000
  • Skill: Advanced
Sound Problems!
« on: 28. August 2013, 07:25:04 »
Hello,
Initially when I installed Manjaro, sometimes the sound seems to work, sometimes it didnt, while it was fine on other distros; till I finally found out what was happening.

Here's how it goes-
Note-I am using the default/standard configuration (pnmixer +alsa +pulseaudio +pavucontrol)

The problem is that it doesnt synchronize well, I will explain what I mean with the help of screenshots.

(left click on your volume icon in the tray -> Volume Control to check what I type)

1.)When I muted my sound via the Fn+F8 key, or by left clicking on the volume icon - > mute,
 the mute icon in the output devices of volume control would be greyed out both in the system tray and the pavucontrol and in notification also. - Pic No 1

2.) But when I unmute it either with the Fn key or by clicking on the icon -> Unmute,
everywhere in the notifications I see that it is unmuted, but in the volume control (pavucontrol) ,
it is Still Muted! - pic no 2

So there you have it! Thats what I mean that its not synchronizing correctly.

This problem could also be the reason, for example, when you plug in your headphones, and the system is showing that the sound is on, whereas In Fact It would be Off in the volume control( pavucontrol) for your headphones output.

In that case try to do
is to click the greyed out mute icon in the volume control to re-anable your sound. - pic no 3

A simple solution if it works, no uninstalling/ reinstalling, or messing with configuration files.  :)
« Last Edit: 13. March 2014, 09:05:41 by aaditya »

Offline nirjhor

  • Neuling
  • *
  • Posts: 20
  • Kernel: 3.10.7-1-MANJARO
  • Desktop: Cinnamon
  • Branch: Stable
  • GPU Card: nVidia 740M
  • GPU driver: Non-Free + Bumblebee
  • Skill: Novice
Re: Sound Problems!
« Reply #1 on: 28. August 2013, 12:11:36 »
I had the problem few days ago, where my headphone weren't getting any sound. I posted a thread here. Turned out, completely shutting down and powering the laptop back up fixed the problem.

Reboot doesn't work though

Offline aadityaTopic starter

  • Support Team
  • ****
  • Posts: 1334
    • My Website
  • Kernel: Linux-3.13-x86_64
  • Desktop: Xfce
  • Branch: Testing
  • GPU Card: Intel HD 4000
  • Skill: Advanced
Re: Sound Problems!
« Reply #2 on: 28. August 2013, 12:30:11 »

Online FadeMind

  • Support Team
  • ****
  • Posts: 654
    • Gravatar
  • Skill: Intermediate
Re: Sound Problems!
« Reply #3 on: 17. October 2013, 11:25:57 »
I added section Troubleshooting. Steam not run proper if u make changes in /etc/asound.conf and U run amixer set Master toggle command.

Offline danieldangol

  • Jr. Mitglied
  • **
  • Posts: 82
  • Kernel: linux310-x64
  • Desktop: Xfce
  • Branch: stable
  • GPU Card: intel/ati hybrid graphics
  • GPU driver: free
  • Skill: Novice
Re: Sound Problems!
« Reply #4 on: 13. November 2013, 04:36:31 »
i had same problem [amixer set Master toggle] code dont do the trick on me... :D may be my bad... for now i'm unmuting the laptop by reinserting earphone jack..only after the unplug the earphone jack laptop speaker came to alive.... i'm searching for better solution...finger crossed. :-\

Offline Richard

  • Sr. Mitglied
  • ****
  • Posts: 274
  • Louisiana en Venezuela
  • Kernel: linux310, 312, 313, 314
  • Desktop: Xfce4
  • Branch: Stable octopi yaourt
  • GPU Card: Intel 2nd Gen.
  • GPU driver: Intel
  • Skill: Intermediate
Re: Sound Problems!
« Reply #5 on: 29. November 2013, 14:36:57 »
Thanks aaditya,

"No sound" has been driving me crazy.  :-\
« Last Edit: 29. November 2013, 15:23:12 by Richard »
ManjaroX, MX-14

Offline aadityaTopic starter

  • Support Team
  • ****
  • Posts: 1334
    • My Website
  • Kernel: Linux-3.13-x86_64
  • Desktop: Xfce
  • Branch: Testing
  • GPU Card: Intel HD 4000
  • Skill: Advanced
Re: Sound Problems!
« Reply #6 on: 29. November 2013, 14:57:00 »
Oh, it puzzled me too for a few days till I found out what was happening :)
In the end I just removed pulseaudio in favour of simple ALSA which is working till date on my system ;)

Offline Richard

  • Sr. Mitglied
  • ****
  • Posts: 274
  • Louisiana en Venezuela
  • Kernel: linux310, 312, 313, 314
  • Desktop: Xfce4
  • Branch: Stable octopi yaourt
  • GPU Card: Intel 2nd Gen.
  • GPU driver: Intel
  • Skill: Intermediate
Re: Sound Problems!
« Reply #7 on: 29. November 2013, 15:03:12 »
I'm going to try that, to see if it will get rid of the low hum. :(

Great! Definite improvement.

Seems something in linux312 brought out the worst in pulseaudio.
Even with linux310 there was a conflict but not too noticeable if the sound was low.
« Last Edit: 29. November 2013, 15:19:50 by Richard »
ManjaroX, MX-14

Offline ringo32

  • Core Team
  • *****
  • Posts: 6341
  • Dutch People look @ manjaro.be or manjaro.nl :)
    • Manjaro Belgium + forum
  • Kernel: linux310 linux313
  • Desktop: I3-Openbox/xfce
  • Branch: unstable
  • GPU Card: Nvidia Geforce 8600 GT (acer 23inch)
  • GPU driver: non-free
  • Skill: Intermediate
Re: Sound Problems!
« Reply #8 on: 29. November 2013, 15:19:15 »
Good topic :)

[irc] www.manjaro.be/irc  #manjaro #manjaro-nl #manjaro-ru #manjaro-es #linuxpark  #manjaro-de #manjaro-fr offtopic #manjaro-talk

Offline aadityaTopic starter

  • Support Team
  • ****
  • Posts: 1334
    • My Website
  • Kernel: Linux-3.13-x86_64
  • Desktop: Xfce
  • Branch: Testing
  • GPU Card: Intel HD 4000
  • Skill: Advanced
Re: Sound Problems!
« Reply #9 on: 29. November 2013, 15:26:43 »
Thx Ringo, it was one of my first topics :)
« Last Edit: 29. November 2013, 15:34:04 by aaditya »

Offline pizzapill

  • Neuling
  • *
  • Posts: 16
  • Skill: Intermediate
Re: Sound Problems!
« Reply #10 on: 14. January 2014, 17:54:16 »
i had same problem [amixer set Master toggle] code dont do the trick on me... :D may be my bad... for now i'm unmuting the laptop by reinserting earphone jack..only after the unplug the earphone jack laptop speaker came to alive.... i'm searching for better solution...finger crossed. :-\

Have you found a solution to your problem? This also affects me and at least two other users.

Offline MrVaykadji

  • Neuling
  • *
  • Posts: 1
  • Skill: Intermediate
Re: Sound Problems!
« Reply #11 on: 14. January 2014, 21:06:23 »
You sir, really deserve a better view on Search Engines ! I looked up for 1 hour before I found your Wiki page and got rid of my problem. Thank you so much.


I had a bug with Manjaro on my Asus Laptop (EeePC), using XFCE (xfce4) : Pulse (pulseaudio) was confusing my speakers with my headphones. That was really annoying, because I always had to open alsamixer, then change the default card for my speakers (HDA Intel), and then raise and increase the headphone's volume in order to get the speakers to work.

Here is the link to the solution : http://wiki.manjaro.org/index.php/Volume_Stuck_on_Mute_%28XFCE_Desktop%29

After that, I had to open xfce4-mixer and enable Auto-Mute Mode (if not, both headphones and speakers were working all the time).
I also had to edit ~/.config/vlc/vlcrc and change the line
Code: [Select]
#alsa-audio-device="default" byt
Code: [Select]
alsa-audio-device=hw:0,0


Some keywords that could have helped my find faster^^ : alsa, arch, pulse-audio, headphones, speakers, manjaro, bug, problem, no sound, auto-mute, 0.8.8
« Last Edit: 15. January 2014, 22:05:14 by MrVaykadji »

Offline tibi

  • Jr. Mitglied
  • **
  • Posts: 63
  • Kernel: linux310-x64
  • Desktop: Xfce
  • Branch: ManjaroLinux 0.8.9 Ascella
  • GPU Card: Intel HD3000 i7 integrated
  • GPU driver: free
  • Skill: Novice
Re: Sound Problems!
« Reply #12 on: 13. March 2014, 08:49:27 »
Just realized this was a problem in my system too. Thanks for making it sticky.