Author Topic: errors while updating update  (Read 870 times)

0 Members and 1 Guest are viewing this topic.

Offline joshuaTopic starter

  • Core Team
  • *****
  • Posts: 780
  • Standing on the shoulders of giants...
  • Kernel: linux311-x86
  • Desktop: KDE / OpenBox
  • Branch: unstable
  • GPU Card: AMD A6-3420M
  • GPU driver: non-free
  • Skill: Advanced
errors while updating update
« on: 31. July 2013, 01:58:42 »
While updating today I had a few problems with updating about file conflicts. The conflicts are with mesa-libgl, lib32-mesa-libgl, lsb-release  and nspr. I took care of by removing the conflicting files.

Here was the information I got while updating.
Code: [Select]
[dcell@manjaro ~]$ sudo pacman -Syu
:: Synchronizing package databases...
 core                                                           103.4 KiB    79.0K/s 00:01 [####################################################] 100%
 extra                                                          1439.4 KiB   295K/s 00:05 [####################################################] 100%
 community                                                 1992.5 KiB   45.6K/s 00:44 [####################################################] 100%
 multilib                                                       106.9 KiB    28.3K/s 00:04 [####################################################] 100%
:: Starting full system upgrade...
:: Replace amd-ucode with core/linux-firmware? [Y/n] y
warning: filesystem: downgrading from version 2013.06-1 to version 2013.05-2
warning: grub: downgrading from version 2.00.5043-3 to version 2.00.5043-2
warning: pacman-mirrorlist: downgrading from version 20130716-1 to version 20130626-1
resolving dependencies...
looking for inter-conflicts...

Packages (74): a52dec-0.7.4-7  akonadi-1.10.2-1  alsa-utils-1.0.27.2-1  amd-ucode-2012.09.10-2 [removal]  anki-2.0.12-1  apache-2.2.25-1
               apr-1.4.8-1  ati-dri-9.1.5-1  avahi-0.6.31-10  cln-1.3.3-1  colord-1.0.2-2  cracklib-2.9.0-1  dosfstools-3.0.22-1
               filesystem-2013.05-2  git-1.8.3.4-1  glib2-2.36.3-3  gnome-vfs-2.24.4-7  gnutls-3.2.3-1  grub-2.00.5043-2  harfbuzz-0.9.19-1
               harfbuzz-icu-0.9.19-1  idnkit-1.0-3  ilmbase-2.0.1-1  intel-dri-9.1.5-1  lib32-ati-dri-9.1.5-1  lib32-libgcrypt-1.5.3-1
               lib32-libpciaccess-0.13.2-1  lib32-libtxc_dxtn-1.0.1-5  lib32-libx11-1.6.1-1  lib32-mesa-9.1.5-1  lib32-mesa-libgl-9.1.5-1
               libdatrie-0.2.6-1  libgcrypt-1.5.3-1  libmariadbclient-5.5.32-1  libmbim-1.4.0-1  libpciaccess-0.13.2-1  libpng-1.6.3-1
               libqmi-1.4.0-2  libthai-0.1.19-1  libusbx-1.0.16-1  libx11-1.6.1-1  libxcb-1.9.1-2  libxfont-1.4.6-1  linux-firmware-20130725-1
               lirc-utils-1:0.9.0-52  lsb-release-1.4-13  mariadb-5.5.32-1  mariadb-clients-5.5.32-1  media-player-info-19-1  mesa-9.1.5-1
               mkinitcpio-busybox-1.21.1-1  modemmanager-1.0.0-1  nfs-utils-1.2.8-9  nmap-6.40-1  nspr-4.10-2  nss-3.15.1-1  ntp-4.2.6.p5-15
               openexr-2.0.1-1  pacman-mirrorlist-20130626-1  phpmyadmin-4.0.4.2-1  qtwebkit-2.3.2-1  refind-efi-0.7.1-4  syslinux-4.07-1
               twisted-13.1.0-1  videoproto-2.3.2-1  virtuoso-base-6.1.7-1  wine-1.6-1  wireshark-cli-1.10.1-1  wireshark-gtk-1.10.1-1
               xcb-proto-1.8-2  xdg-utils-1.1.0.git20130520-1  xorg-iceauth-1.0.6-1  xscreensaver-5.22-1  mesa-libgl-9.1.5-1

Total Download Size:    4.93 MiB
Total Installed Size:   977.05 MiB
Net Upgrade Size:       10.75 MiB

:: Proceed with installation? [Y/n] y
:: Retrieving packages ...
 filesystem-2013.05-2-x86_64                                      8.4 KiB  0.00B/s 00:00 [####################################################] 100%
 grub-2.00.5043-2-x86_64                                          4.9 MiB   676K/s 00:07 [####################################################] 100%
 pacman-mirrorlist-20130626-1-any                                 2.7 KiB  0.00B/s 00:00 [####################################################] 100%
(73/73) checking keys in keyring                                                         [####################################################] 100%
(73/73) checking package integrity                                                       [####################################################] 100%
(73/73) loading package files                                                            [####################################################] 100%
(73/73) checking for file conflicts                                                      [####################################################] 100%
error: failed to commit transaction (conflicting files)
mesa-libgl: /usr/lib/libGL.so exists in filesystem
mesa-libgl: /usr/lib/libGL.so.1 exists in filesystem
mesa-libgl: /usr/lib/libGL.so.1.2.0 exists in filesystem
mesa-libgl: /usr/lib/xorg/modules/extensions/libglx.so exists in filesystem
lib32-mesa-libgl: /usr/lib32/libGL.so exists in filesystem
lib32-mesa-libgl: /usr/lib32/libGL.so.1 exists in filesystem
lib32-mesa-libgl: /usr/lib32/libGL.so.1.2.0 exists in filesystem
lsb-release: /etc/lsb-release exists in filesystem
nspr: /usr/share/aclocal/nspr.m4 exists in filesystem
Errors occurred, no packages were upgraded.

And here's what I did to fix it.

Code: [Select]
sudo rm /usr/lib/libGL.so /usr/lib/libGL.so.1 /usr/lib/libGL.so.1.2.0 /usr/lib/xorg/modules/extensions/libglx.so /usr/lib32/libGL.so /usr/lib32/libGL.so.1 /usr/lib32/libGL.so.1.2.0 /etc/lsb-release /usr/share/aclocal/nspr.m4
sudo pacman -Syu

Well enough to say I probably shouldn't have done this. After a reboot I just got to the point where my KDM should have started and instead I got a blinking cursor in the upper left hand corner. I Couldn't drop to a tty so I just chrooted in from another live distro and found out trying to downgrade or reinstall those packages is like dependency hell... So after a while I just removed all my catalyst stuff and drivers and wen't back to a free driver.

Code: [Select]
sudo mhwd -i pci video-ati
sudo pacman -S xorg-server

So I got everything back to normal except I'm still running on a free driver. pacman is still being a little funky though. When I try to update I get these warnings.

Code: [Select]
[dcell@manjaro ~]$ sudo pacman -Syu
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
:: Starting full system upgrade...
warning: filesystem: local (2013.06-1) is newer than core (2013.05-2)
warning: grub: local (2.00.5043-3) is newer than core (2.00.5043-2)
warning: pacman-mirrorlist: local (20130716-1) is newer than core (20130626-1)
 there is nothing to do

Anyone have any ideas on how to fix this problem? Also why did this happen? I'm afraid to go back to using my catalyst drivers because I don't want to have a repeat of this... Thanks in advance  ;D.


rfk1ll

  • Guest
Re: errors while updating update
« Reply #1 on: 31. July 2013, 02:16:53 »

 ;)

rfk1ll

  • Guest
Re: errors while updating update
« Reply #2 on: 31. July 2013, 03:34:22 »
sorry dcell. I couldn't resist. :) you need to change mirrors, you have one thats behind . then resync with -Syy 

Offline joshuaTopic starter

  • Core Team
  • *****
  • Posts: 780
  • Standing on the shoulders of giants...
  • Kernel: linux311-x86
  • Desktop: KDE / OpenBox
  • Branch: unstable
  • GPU Card: AMD A6-3420M
  • GPU driver: non-free
  • Skill: Advanced
Re: errors while updating update
« Reply #3 on: 31. July 2013, 06:14:28 »
That fixed me. I'm pretty sure it was reflector that caused this problem. My mirror list was pretty messed up so after generating a new mirror list I got a few updates and everything ran well again. Haven't had a chance to set up my catalyst yet but I'm pretty confident it will work  ;D. Although now I get way more problems while updating. I have a feeling is what happened was reflector synced me to the arch mirrors and I got later versions of everything...

Code: [Select]
[dcell@manjaro ~]$ sudo pacman -Syu
[sudo] password for dcell:                                                                                                                                                                                                       
:: Synchronizing package databases...                                                                                                                                                                                           
 core is up to date                                                                                                                                                                                                             
 extra is up to date
 community is up to date
 multilib is up to date
:: Starting full system upgrade...
warning: akonadi: local (1.10.2-1) is newer than extra (1.10.1-1)
warning: alsa-utils: local (1.0.27.2-1) is newer than extra (1.0.27.1-2)
warning: cracklib: local (2.9.0-1) is newer than core (2.8.22-3)
warning: dosfstools: local (3.0.22-1) is newer than core (3.0.20-1)
warning: gnutls: local (3.2.3-1) is newer than extra (3.2.2-1)
warning: grub-customizer: local (3.0.4-2) is newer than extra (3.0.4-1)
warning: ilmbase: local (2.0.1-1) is newer than extra (2.0.0-1)
warning: lib32-libgcrypt: local (1.5.3-1) is newer than multilib (1.5.2-1)
warning: lib32-libx11: local (1.6.1-1) is newer than multilib (1.6.0-1)
warning: libgcrypt: local (1.5.3-1) is newer than core (1.5.2-1)
warning: libx11: local (1.6.1-1) is newer than extra (1.6.0-1)
warning: linux-firmware: local (20130725-1) is newer than core (20130610-1)
warning: lsb-release: local (1.4-13) is newer than core (1.4-12)
warning: media-player-info: local (19-1) is newer than extra (17-1)
warning: mkinitcpio-busybox: local (1.21.1-1) is newer than core (1.20.2-1)
warning: nmap: local (6.40-1) is newer than extra (6.25-2)
warning: nspr: local (4.10-2) is newer than extra (4.9.6-1)
warning: nss: local (3.15.1-1) is newer than extra (3.14.3-3)
warning: openexr: local (2.0.1-1) is newer than extra (2.0.0-1)
warning: phpmyadmin: local (4.0.4.2-1) is newer than community (4.0.4.1-1)
warning: syslinux: local (4.07-1) is newer than core (4.06-2)
warning: virtuoso-base: local (6.1.7-1) is newer than extra (6.1.6-2)
warning: wireshark-cli: local (1.10.1-1) is newer than extra (1.10.0-3)
warning: wireshark-gtk: local (1.10.1-1) is newer than extra (1.10.0-3)
warning: xdg-utils: local (1.1.0.git20130520-1) is newer than extra (1.1.0.git20121008-2)
 there is nothing to do

I have a feeling when updates for these packages come out in manjaro they'll go away so unless anyone knows a solution to fix those I'll mark this thread as solved  ;).

Online ringo32

  • Core Team
  • *****
  • Posts: 6335
  • Dutch People look @ manjaro.be or manjaro.nl :)
    • Manjaro Belgium + forum
  • Kernel: linux310 linux313
  • Desktop: I3-Openbox/xfce
  • Branch: unstable
  • GPU Card: Nvidia Geforce 8600 GT (acer 23inch)
  • GPU driver: non-free
  • Skill: Intermediate
Re: errors while updating update
« Reply #4 on: 31. July 2013, 08:34:29 »
havel you also switched from test/unstable and back to stable? amd-ucode update i had few days a goo in unstable :o was renamed to linux-firmware or something ?
$:)

[irc] www.manjaro.be/irc  #manjaro #manjaro-nl #manjaro-ru #manjaro-es #linuxpark  #manjaro-de #manjaro-fr offtopic #manjaro-talk