Author Topic: How to change keyboard layout in Cinnamon desktop  (Read 7021 times)

0 Members and 1 Guest are viewing this topic.

Offline HaikuTopic starter

  • Neuling
  • *
  • Posts: 47
    • WriteLinux
  • Kernel: Linux311-x64
  • Desktop: Openbox
  • Branch: Stable
  • GPU Card: nVidia GeForce GT 540M
  • GPU driver: free
  • Skill: Intermediate
How to change keyboard layout in Cinnamon desktop
« on: 28. May 2013, 10:45:31 »
Hi all

In Manjaro Cinnamon edition there are a lot of places to change keyboard layout and add Input Sources like in System Settings(Keyboard or Regional Settings) and also there is a entry in Manjaro Settings Manager for that but none of these work for me. I set Input Sources for my language and English and now I want to switch between them but there isn't any shortcut on the keyboard to switch between them. Somewhere in the settings it said use Super+Space to change or somewhere in Regional Settings or Tweak Tools I set Alt+Shift for that but none of them work in here and I just can click on the flags indicator in my Cinnamon Panel to change layout and yet no shortcut for it.

I also have read http://forum.manjaro.org/index.php?topic=1890.0 but nothing has happened there!

Thanks

Offline Saeed Iranzad

  • Vollwertiges Mitglied
  • ***
  • Posts: 154
  • Kernel: linux310-x64
  • Desktop: XFCE
  • Branch: stable
  • GPU Card: Intel(integrated)
  • GPU driver: Intel
  • Skill: Novice
Re: How to change keyboard layout in Cinnamon desktop
« Reply #1 on: 28. May 2013, 11:37:06 »
Hi
It's really easy. I have Mate, but the method is the same.
System>Preferences>Keyboard>Layout-tab>Options
Now click on [+keys to change layout]
And choose your option.

Offline HaikuTopic starter

  • Neuling
  • *
  • Posts: 47
    • WriteLinux
  • Kernel: Linux311-x64
  • Desktop: Openbox
  • Branch: Stable
  • GPU Card: nVidia GeForce GT 540M
  • GPU driver: free
  • Skill: Intermediate
Re: How to change keyboard layout in Cinnamon desktop
« Reply #2 on: 28. May 2013, 12:08:43 »
Hi
It's really easy. I have Mate, but the method is the same.
System>Preferences>Keyboard>Layout-tab>Options
Now click on [+keys to change layout]
And choose your option.

Hi Saeed, Thanks for the answer.
I'm actually aware of that settings you said 'cause I used many different distributions, but keyboard settings in Manjaro Cinnamon doesn't have that layout tab you mentioned:


Offline xircon

  • Held Mitglied
  • *****
  • Posts: 543
  • Kernel: 3.12.1-1 x86_64 (Always the newest!)
  • Desktop: Compiz stand-a-lone
  • Branch: Unstable
  • GPU Card: ATI 5400
  • GPU driver: free
  • Skill: Advanced
Re: How to change keyboard layout in Cinnamon desktop
« Reply #3 on: 28. May 2013, 22:02:02 »
Use either the gnome-control-center or perhaps manjaro-settings-manager?

Steve
Dell Inspiron N5010 Core i5 Radeon HD5400 tracking unstable

Offline Saeed Iranzad

  • Vollwertiges Mitglied
  • ***
  • Posts: 154
  • Kernel: linux310-x64
  • Desktop: XFCE
  • Branch: stable
  • GPU Card: Intel(integrated)
  • GPU driver: Intel
  • Skill: Novice
Re: How to change keyboard layout in Cinnamon desktop
« Reply #4 on: 29. May 2013, 04:33:44 »
Hi Saeed, Thanks for the answer.
I'm actually aware of that settings you said 'cause I used many different distributions, but keyboard settings in Manjaro Cinnamon doesn't have that layout tab you mentioned:


It's weird. I don't know. I have Cinnamon on Mint. I'll check it.

Offline HaikuTopic starter

  • Neuling
  • *
  • Posts: 47
    • WriteLinux
  • Kernel: Linux311-x64
  • Desktop: Openbox
  • Branch: Stable
  • GPU Card: nVidia GeForce GT 540M
  • GPU driver: free
  • Skill: Intermediate
Re: How to change keyboard layout in Cinnamon desktop
« Reply #5 on: 29. May 2013, 11:42:29 »
Use either the gnome-control-center or perhaps manjaro-settings-manager?
gnome-control-center is what you see in the above picture, there isn't any layout tab in it.
it just said use Super+Space to change layout but it doesn't affect anything in here.

It's weird. I don't know. I have Cinnamon on Mint. I'll check it.
Yeah, in Cinnamon on Mint everything is fine but this one on Manjaro is different!

Offline Culinax

  • Support Team
  • ****
  • Posts: 1042
    • Culinax - Home
  • Kernel: Linux313-x64
  • Desktop: Awesome 3.5
  • Branch: Unstable
  • GPU Card: NVIDIA GeForce 710M - Intel (Optimus)
  • GPU driver: Free Driver
  • Skill: Intermediate
Re: How to change keyboard layout in Cinnamon desktop
« Reply #6 on: 29. May 2013, 16:22:16 »
You might want to take a look at this to do it the manual way: http://wiki.manjaro.org/index.php?title=Keyboard_Layout#Switch_between_keyboard_layouts
Open  /etc/X11/xorg.conf.d/10-evdev.conf  as root. Then replace/insert the following code to change between 2 layouts with alt+shift. (Don't forget to change the layouts after XkbLayout)
Code: [Select]
        Option "XkbLayout" "be,us(colemak)"
        Option "XkbOptions" "grp:alt_shift_toggle,grp_led:scroll"
Manjaro Awesome WM Respin: Current version: 0.8.8-b4.1
Belgian/Dutch Manjaro Linux users: unite! http://manjaro.be/ | IRC: #manjaro-nl
My small site with my dotfiles

Offline HaikuTopic starter

  • Neuling
  • *
  • Posts: 47
    • WriteLinux
  • Kernel: Linux311-x64
  • Desktop: Openbox
  • Branch: Stable
  • GPU Card: nVidia GeForce GT 540M
  • GPU driver: free
  • Skill: Intermediate
Re: How to change keyboard layout in Cinnamon desktop
« Reply #7 on: 30. May 2013, 08:41:29 »
You might want to take a look at this to do it the manual way: http://wiki.manjaro.org/index.php?title=Keyboard_Layout#Switch_between_keyboard_layouts
Open  /etc/X11/xorg.conf.d/10-evdev.conf  as root. Then replace/insert the following code to change between 2 layouts with alt+shift. (Don't forget to change the layouts after XkbLayout)
Code: [Select]
        Option "XkbLayout" "be,us(colemak)"
        Option "XkbOptions" "grp:alt_shift_toggle,grp_led:scroll"

I also do this, this file looks like this for me:
Code: [Select]
Section "InputClass"
        Identifier "evdev keyboard catchall"
Option "XkbLayout" "us,fa"
        Option "XkbOptions" "grp:alt_shift_toggle,grp_led:scroll"
        MatchIsKeyboard "on"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"
EndSection

but nothing happens again.
But now when I reboot, in the boot screen when everything runs and check as [OK], I see the "keyboardctl service" [FAILED] to run!

Offline HaikuTopic starter

  • Neuling
  • *
  • Posts: 47
    • WriteLinux
  • Kernel: Linux311-x64
  • Desktop: Openbox
  • Branch: Stable
  • GPU Card: nVidia GeForce GT 540M
  • GPU driver: free
  • Skill: Intermediate
Re: How to change keyboard layout in Cinnamon desktop
« Reply #8 on: 30. June 2013, 14:56:17 »
Friends I still have this simple problem of swithching keyboard layouts in Cinnamon desktop!
Seriously, no one else uses Cinnamon who has to use 2 layouts for keyboard?

Offline rom85

  • Neuling
  • *
  • Posts: 8
  • Kernel: 3.12
  • Desktop: Xfce
  • Branch: stable
  • GPU Card: Intel
  • GPU driver: free
  • Skill: Intermediate
Re: How to change keyboard layout in Cinnamon desktop
« Reply #9 on: 03. July 2013, 13:22:10 »
I'm ready to confirm the symptoms that Haiku has. I've also tried all of the mentioned advices and their combinations and none of them helped. I'm still switching layouts by mouse through flag icon clicking,- and that is awfully inconvenient.
What's more interesting is that I had layout switching previously, but probably after updates something became broken. One thing to add, is unability to have different layouts in separate programs, it is the same everywhere and setting "Allow different layouts for individual windows" option doesn't work.
That's a pity as I can't use Manjaro Cinnamon edition at work productively.

Offline Culinax

  • Support Team
  • ****
  • Posts: 1042
    • Culinax - Home
  • Kernel: Linux313-x64
  • Desktop: Awesome 3.5
  • Branch: Unstable
  • GPU Card: NVIDIA GeForce 710M - Intel (Optimus)
  • GPU driver: Free Driver
  • Skill: Intermediate
Re: How to change keyboard layout in Cinnamon desktop
« Reply #10 on: 03. July 2013, 13:48:04 »
Does it work when you type the following in your terminal? (No reboot necessary for this)
Code: [Select]
setxkbmap -layout "us,fa" -option "grp:alt_shift_toggle"

I just checked my own configuration and it seems like Manjaro now uses /etc/X11/xorg.conf.d/20-keyboard.conf to configure the keyboard (instead of 10-evdev.conf). Maybe you could try to make that file and put the following in it (example comes from the Arch wiki: https://wiki.archlinux.org/index.php/Xorg#Switching_between_keyboard_layouts)
Code: [Select]
# /etc/X11/xorg.conf.d/20-keyboard.conf

Section "InputClass"
        Identifier             "keyboard-layout"
        MatchIsKeyboard        "on"
        Option "XkbLayout"     "us, fa"
        Option "XkbOptions"    "grp:alt_shift_toggle"
EndSection

It's possible that you might have to remove the appropiate part from 10-evdev.conf (the part where you set the same options as above) because it could conflict with the new keyboard.conf file.

If keyboardctl gives errors, then you maybe could try to disable it to avoid letting it overwrite your manually added settings.
Manjaro Awesome WM Respin: Current version: 0.8.8-b4.1
Belgian/Dutch Manjaro Linux users: unite! http://manjaro.be/ | IRC: #manjaro-nl
My small site with my dotfiles

Offline HaikuTopic starter

  • Neuling
  • *
  • Posts: 47
    • WriteLinux
  • Kernel: Linux311-x64
  • Desktop: Openbox
  • Branch: Stable
  • GPU Card: nVidia GeForce GT 540M
  • GPU driver: free
  • Skill: Intermediate
Re: How to change keyboard layout in Cinnamon desktop
« Reply #11 on: 04. July 2013, 10:08:46 »
Does it work when you type the following in your terminal? (No reboot necessary for this)
Code: [Select]
setxkbmap -layout "us,fa" -option "grp:alt_shift_toggle"
Thanks Culinax for the answer. This command ends up with this:
Code: [Select]
Error loading new keyboard description
I just checked my own configuration and it seems like Manjaro now uses /etc/X11/xorg.conf.d/20-keyboard.conf to configure the keyboard (instead of 10-evdev.conf). Maybe you could try to make that file and put the following in it (example comes from the Arch wiki: https://wiki.archlinux.org/index.php/Xorg#Switching_between_keyboard_layouts)
Code: [Select]
# /etc/X11/xorg.conf.d/20-keyboard.conf

Section "InputClass"
        Identifier             "keyboard-layout"
        MatchIsKeyboard        "on"
        Option "XkbLayout"     "us, fa"
        Option "XkbOptions"    "grp:alt_shift_toggle"
EndSection

It's possible that you might have to remove the appropiate part from 10-evdev.conf (the part where you set the same options as above) because it could conflict with the new keyboard.conf file.

If keyboardctl gives errors, then you maybe could try to disable it to avoid letting it overwrite your manually added settings.
Yes, I also have this new /etc/X11/xorg.conf.d/20-keyboard.conf file. In the beginning of this file it has this comment:
Code: [Select]
# Keyboard layout - Don't modify! Use keyboardctl instead!But I changed it anyway to this:
Code: [Select]
Section "InputClass"
    Identifier "system-keyboard"
    MatchIsKeyboard "on"
    Option "XkbModel" "pc105"
    Option "XkbLayout" "us, fa"
    Option "XkbOptions" "grp:alt_shift_toggle"
    Option "XkbVariant" ""
EndSection
And for now this keyboardctl thing doesn't overwrite my mannual configuration, But still nothing works and it's just like it was before.

Offline ringo32

  • Core Team
  • *****
  • Posts: 6320
  • Dutch People look @ manjaro.be or manjaro.nl :)
    • Manjaro Belgium + forum
  • Kernel: linux310 linux313
  • Desktop: I3-Openbox/xfce
  • Branch: unstable
  • GPU Card: Nvidia Geforce 8600 GT (acer 23inch)
  • GPU driver: non-free
  • Skill: Intermediate
Re: How to change keyboard layout in Cinnamon desktop
« Reply #12 on: 04. July 2013, 10:29:03 »
do sudo systemctl status keyboardctl  , to look the status of it..
if its not loaded? sudo systemctl enable keyboardctl ?

[irc] www.manjaro.be/irc  #manjaro #manjaro-nl #manjaro-ru #manjaro-es #linuxpark  #manjaro-de #manjaro-fr offtopic #manjaro-talk

Offline HaikuTopic starter

  • Neuling
  • *
  • Posts: 47
    • WriteLinux
  • Kernel: Linux311-x64
  • Desktop: Openbox
  • Branch: Stable
  • GPU Card: nVidia GeForce GT 540M
  • GPU driver: free
  • Skill: Intermediate
Re: How to change keyboard layout in Cinnamon desktop
« Reply #13 on: 04. July 2013, 16:42:30 »
do sudo systemctl status keyboardctl  , to look the status of it..
if its not loaded? sudo systemctl enable keyboardctl ?
I think there is no problem with keyboardctl:
Code: [Select]
$ sudo systemctl status keyboardctl

keyboardctl.service - Setup keyboard layout
   Loaded: loaded (/usr/lib/systemd/system/keyboardctl.service; enabled)
   Active: inactive (dead) since Thu 2013-07-04 23:17:22 IRDT
     Docs: man:keyboardctl
  Process: 178 ExecStart=/usr/bin/keyboardctl --setup (code=exited, status=0/SUCCESS)

Jul 04 23:17:22 heaven systemd[1]: Started Setup keyboard layout.


Offline Saeed Iranzad

  • Vollwertiges Mitglied
  • ***
  • Posts: 154
  • Kernel: linux310-x64
  • Desktop: XFCE
  • Branch: stable
  • GPU Card: Intel(integrated)
  • GPU driver: Intel
  • Skill: Novice
Re: How to change keyboard layout in Cinnamon desktop
« Reply #14 on: 04. July 2013, 16:59:37 »
Does it work when you type the following in your terminal? (No reboot necessary for this)
Code: [Select]
setxkbmap -layout "us,fa" -option "grp:alt_shift_toggle"
Sorry, fa is for Persian. I think Haiku is Japanese.
I think my previous posts made you mistake about it.