Author Topic: pacman 4.1 request  (Read 2523 times)

0 Members and 1 Guest are viewing this topic.

Offline z1lt0idTopic starter

  • Neuling
  • *
  • Posts: 41
  • Kernel: linux310-x86
  • Desktop: Awesome
  • Branch: stable
  • GPU Card: Nvidia GS7600
  • GPU driver: Nouveau
  • Skill: Guru
pacman 4.1 request
« on: 05. April 2013, 00:53:10 »
Hi Devs,

Was wondering if you could put Pacman 4.1 from the Arch testing repos into the unstable repos of Manjaro.  I am find a lot of aur git packages will not compile now due to it having a pacman 4.1 dependency.


Offline philm

  • Core Team
  • *****
  • Posts: 5621
    • Manjaro Linux
  • Kernel: Maintainer - so all ;)
  • Desktop: XFCE
  • Branch: Unstable
  • GPU Card: Geforce GTX 650
  • GPU driver: non-free
  • Skill: Guru
Re: pacman 4.1 request
« Reply #1 on: 05. April 2013, 02:19:47 »
Well, we keep pacman 4.0-series for a while. We can't move to 4.1-series yet. A lot of our own tools depend on the old series.

Quote from: Guillaume Benoit
Yes we have to wait, libalpm 4.1 will break pamac. It seems that the new version of pyalpm supporting libalpm 4.1 is almost ready.
I will finish pamac 0.6 that use libalpm 4.0 and then I will port it to libalpm 4.1.
We have to adopt pacman 4.1 and the ported pamac as the same time in our repos to not break anything.

It will take some time until we have adopted to the new upstream changes. For the time being we will move some older packages to our addon repository and blacklist them, such as pacman from getting synced from Arch-Servers. Maybe a list of "broken" packages can be started so we can check what needed to be worked on ...

Offline z1lt0idTopic starter

  • Neuling
  • *
  • Posts: 41
  • Kernel: linux310-x86
  • Desktop: Awesome
  • Branch: stable
  • GPU Card: Nvidia GS7600
  • GPU driver: Nouveau
  • Skill: Guru
Re: pacman 4.1 request
« Reply #2 on: 05. April 2013, 02:29:22 »
That is a shame.  Thanks anyway, guess I'll just have to wait.

Offline xircon

  • Held Mitglied
  • *****
  • Posts: 544
  • Kernel: 3.12.1-1 x86_64 (Always the newest!)
  • Desktop: Compiz stand-a-lone
  • Branch: Unstable
  • GPU Card: ATI 5400
  • GPU driver: free
  • Skill: Advanced
Re: pacman 4.1 request
« Reply #3 on: 12. April 2013, 09:29:03 »
"Broken" Packages so far:
granite-bzr
gala-bzr
lightdm-ubuntu
nemo-git

But I don't think lightdm-ubuntu problem is caused by pacman.

Cheers

Steve
Dell Inspiron N5010 Core i5 Radeon HD5400 tracking unstable

Offline philm

  • Core Team
  • *****
  • Posts: 5621
    • Manjaro Linux
  • Kernel: Maintainer - so all ;)
  • Desktop: XFCE
  • Branch: Unstable
  • GPU Card: Geforce GTX 650
  • GPU driver: non-free
  • Skill: Guru
Re: pacman 4.1 request
« Reply #4 on: 13. April 2013, 12:33:15 »
pacman 4.1 landed now in unstable. Please report any issues you my find with it and pamac.

Offline xircon

  • Held Mitglied
  • *****
  • Posts: 544
  • Kernel: 3.12.1-1 x86_64 (Always the newest!)
  • Desktop: Compiz stand-a-lone
  • Branch: Unstable
  • GPU Card: ATI 5400
  • GPU driver: free
  • Skill: Advanced
Re: pacman 4.1 request
« Reply #5 on: 13. April 2013, 12:35:43 »
Which repo is the main repo (first to update?). Only on my way to work in 20 minutes and I want to test :)

Cheers

Steve
Dell Inspiron N5010 Core i5 Radeon HD5400 tracking unstable

Offline tun in a cellar

  • Held Mitglied
  • *****
  • Posts: 549
  • Kernel: linux313-x64 (the latest if possible)
  • Desktop: XFCE
  • Branch: Unstable
  • GPU Card: Hybrid graphic card (Intel/ATI)
  • GPU driver: free (the discrete card is switched off)
  • Skill: Advanced
Re: pacman 4.1 request
« Reply #6 on: 13. April 2013, 12:52:24 »
pacman 4.1 landed now in unstable. Please report any issues you my find with it and pamac.

I tried and failed:
package-query requires pacman<4.1

Additional question: What happens if I install pacman 4.1? Will pamac still work?
« Last Edit: 13. April 2013, 12:59:20 by tun in a cellar »
Why doing it yourself when manjaro-system can do it for you?

Offline ringo32

  • Core Team
  • *****
  • Posts: 6323
  • Dutch People look @ manjaro.be or manjaro.nl :)
    • Manjaro Belgium + forum
  • Kernel: linux310 linux313
  • Desktop: I3-Openbox/xfce
  • Branch: unstable
  • GPU Card: Nvidia Geforce 8600 GT (acer 23inch)
  • GPU driver: non-free
  • Skill: Intermediate
Re: pacman 4.1 request
« Reply #7 on: 13. April 2013, 13:05:04 »
yep here too ;)

[irc] www.manjaro.be/irc  #manjaro #manjaro-nl #manjaro-ru #manjaro-es #linuxpark  #manjaro-de #manjaro-fr offtopic #manjaro-talk

Offline ringo32

  • Core Team
  • *****
  • Posts: 6323
  • Dutch People look @ manjaro.be or manjaro.nl :)
    • Manjaro Belgium + forum
  • Kernel: linux310 linux313
  • Desktop: I3-Openbox/xfce
  • Branch: unstable
  • GPU Card: Nvidia Geforce 8600 GT (acer 23inch)
  • GPU driver: non-free
  • Skill: Intermediate
Re: pacman 4.1 request
« Reply #8 on: 13. April 2013, 13:14:01 »
package-query is needed by yaourt.... looking for yaourt through archlinux, no yaourt?

[irc] www.manjaro.be/irc  #manjaro #manjaro-nl #manjaro-ru #manjaro-es #linuxpark  #manjaro-de #manjaro-fr offtopic #manjaro-talk

Offline xircon

  • Held Mitglied
  • *****
  • Posts: 544
  • Kernel: 3.12.1-1 x86_64 (Always the newest!)
  • Desktop: Compiz stand-a-lone
  • Branch: Unstable
  • GPU Card: ATI 5400
  • GPU driver: free
  • Skill: Advanced
Re: pacman 4.1 request
« Reply #9 on: 13. April 2013, 13:14:42 »
Ringo - which mirror are you using, not got time to play now, must go to work
Dell Inspiron N5010 Core i5 Radeon HD5400 tracking unstable

Offline ringo32

  • Core Team
  • *****
  • Posts: 6323
  • Dutch People look @ manjaro.be or manjaro.nl :)
    • Manjaro Belgium + forum
  • Kernel: linux310 linux313
  • Desktop: I3-Openbox/xfce
  • Branch: unstable
  • GPU Card: Nvidia Geforce 8600 GT (acer 23inch)
  • GPU driver: non-free
  • Skill: Intermediate
Re: pacman 4.1 request
« Reply #10 on: 13. April 2013, 13:21:58 »
french :)

yaourt has blocked....the update so i deleted yaourt and package-query :)

after that i couldnt find yaourt so i reinstall a newer yaourt version and package-query

[irc] www.manjaro.be/irc  #manjaro #manjaro-nl #manjaro-ru #manjaro-es #linuxpark  #manjaro-de #manjaro-fr offtopic #manjaro-talk

Offline ringo32

  • Core Team
  • *****
  • Posts: 6323
  • Dutch People look @ manjaro.be or manjaro.nl :)
    • Manjaro Belgium + forum
  • Kernel: linux310 linux313
  • Desktop: I3-Openbox/xfce
  • Branch: unstable
  • GPU Card: Nvidia Geforce 8600 GT (acer 23inch)
  • GPU driver: non-free
  • Skill: Intermediate
Re: pacman 4.1 request
« Reply #11 on: 13. April 2013, 13:32:50 »
have compiled yaourt from archlinux ...only yeah it set manjaro-keyring to orphan.. so i have reinstalled but stil in orphan , have marked as Explicited again :)
so  pacman 4.1 updates need also new yaourt and package-query.., but i dont know in the other mirrors yaourt seems to be gone?

have compiled from here http://archlinux.fr/yaourt-en    ...

[irc] www.manjaro.be/irc  #manjaro #manjaro-nl #manjaro-ru #manjaro-es #linuxpark  #manjaro-de #manjaro-fr offtopic #manjaro-talk

Offline tun in a cellar

  • Held Mitglied
  • *****
  • Posts: 549
  • Kernel: linux313-x64 (the latest if possible)
  • Desktop: XFCE
  • Branch: Unstable
  • GPU Card: Hybrid graphic card (Intel/ATI)
  • GPU driver: free (the discrete card is switched off)
  • Skill: Advanced
Re: pacman 4.1 request
« Reply #12 on: 13. April 2013, 13:48:51 »
package-query is needed by yaourt.... looking for yaourt through archlinux, no yaourt?
You will never found yaourt in official arch repo even if this package is popular in AUR.
Have a look [ur=https://wiki.archlinux.org/index.php/Yaourtl]here[/url]

Yaourt is developped and maintained by a French guy from the French community of Archlinux

I guess that yaourt was adapted in order to be pacman 4.1 complient.

I will try this:
switch to stable again
remove yaourt
switch to unstable
upgrade the system
wait for yaourt being updated

stay tuned...
Why doing it yourself when manjaro-system can do it for you?

Offline ringo32

  • Core Team
  • *****
  • Posts: 6323
  • Dutch People look @ manjaro.be or manjaro.nl :)
    • Manjaro Belgium + forum
  • Kernel: linux310 linux313
  • Desktop: I3-Openbox/xfce
  • Branch: unstable
  • GPU Card: Nvidia Geforce 8600 GT (acer 23inch)
  • GPU driver: non-free
  • Skill: Intermediate
Re: pacman 4.1 request
« Reply #13 on: 13. April 2013, 13:58:00 »
i have just remove it and install other one :o  in the repo isnt also
yaourt

Code: [Select]
[ringo@manjaro ~]$ sudo pacman -Si yaourt
error: package 'yaourt' was not found
[ringo@manjaro ~]$

pamac works ok, only on Orphan handling  as alo an option to make Explecite... and after some removal from orphanage it stuck for even try to replicate but didnt again... shall see furter it works..

[irc] www.manjaro.be/irc  #manjaro #manjaro-nl #manjaro-ru #manjaro-es #linuxpark  #manjaro-de #manjaro-fr offtopic #manjaro-talk

Offline tun in a cellar

  • Held Mitglied
  • *****
  • Posts: 549
  • Kernel: linux313-x64 (the latest if possible)
  • Desktop: XFCE
  • Branch: Unstable
  • GPU Card: Hybrid graphic card (Intel/ATI)
  • GPU driver: free (the discrete card is switched off)
  • Skill: Advanced
Re: pacman 4.1 request
« Reply #14 on: 13. April 2013, 13:59:44 »
Bingo!
After having switched to stable, removed yaourt (pacman -Rcsn yaourt) and switched to unstable, I coud installed pacman 4.1

pacman.conf.pacnew was created => let's have a look at it...

Stay tuned...
Why doing it yourself when manjaro-system can do it for you?